Visual Studio Code Intellisense (autocomplete) not working


I am trying to use Visual Studio Code instead of Visual Studio for a C# project, but Visual Studio code Intellisense (Autocomplete) suggestion is not working correctly, and doesn't show any suggestions when using Ctrl+Space, shortcut.

What can be the issues? Any suggestions, thanks.


Asked by:- neena
1
: 574 At:- 4/10/2022 12:34:04 PM
C# Visual Studio Code







1 Answers
profileImage Answered by:- vikas_jk

You can try these solutions

Solution 1

Try to set these settings correctly

"editor.quickSuggestions": true,
"editor.suggestOnTriggerCharacters": true,

Solution 2

If you have done the above settings correctly, then you should check this for C#

Visual Studio Code's advanced editing features like IntelliSense, refactoring tools, etc. only work in C# files if you have a project.json file or *.sln file that VSCode is aware of.

So you should open a project folder with the *.sln file or project.json and VSCode will attempt to find all project/solution files in the folder.

If there are multiple projects, you may need to select one from the projects button on the right side of the status bar (bottom of the window).

Solution 3

Try to check if the Omnisharp extension for C# has the correct settings, once you have downloaded this extension.

  • Click 'Ctrl + Shift + P'.
  • Write "OmniSharp: Select Project" and press Enter.
  • Choose the solution workspace entry.
  • Then enable the C# extension for "OmniSharp: Project".

Solution 4

Get the latest version of Omnisharp, you can do this by setting the flag to update to the latest version in Settings.json file.

"omnisharp.path": "latest"

and then restart VS code.

If you are using any other language than C#, you can try to install the correct programming language IntelliSense from here

https://code.visualstudio.com/docs/editor/intellisense

Solution 5 (If you want to enable Tab Autocomplete)

Try changing tab-completion setting to On:

Editor -> tab Completion

"editor.tabCompletion": "on"

thanks.

1
At:- 4/10/2022 12:51:53 PM
Thanks, Solution 3 works for me. 0
By : neena - at :- 4/10/2022 12:59:14 PM






Login/Register to answer
Or
Register directly by posting answer/details

Full Name *

Email *




By posting your answer you agree on privacy policy & terms of use