Cannot find the check box for enabling SSL in visual studio 2017 (ASP.NET Core project)


Hi, I want to enable SSL for my ASP.NET Core project in Visual studio 2017, but when I'm checking my visual studio project to enable SSL, it looks like this in properties

no_ssl-min.png

Should have like this to enable SSL

enable-ssl-visual-studio-2017-min.png

Please, can you give me an explanation why I'm not having this option and how I can add it . Thanks.


Asked by:- LuneAgile
0
: 73 At:- 9/21/2018 3:45:33 PM
ASP.NET enable-ssl-in-asp-net-core visual-studio






3 Answers
profileImage Answered by:- manish

I tried to create ASP.NET Core 2.1 project in my Visual Studio 2017 and was able to see "Enable https" option

While creating New project select properties properly

asp-net-core-https-visual-studio-min.png

After creating the project, right click on ProjectName inside Solution explorer, and select "Debug" tab you should see this option

https-enable-in-visual-studio-asp-net-core-min.png

I am using Visual studio 2017 community version, in which I have installed everything in .NET Core and Web.

1
At:- 10/13/2018 1:02:18 PM
Thanks Manish The problem that I was lunch my website using publish with IIS and kestrel so when I change the option lunch under debug to project not to IIS express the option enable ssl is not appear in lunch project but appear in lunch IIS express. Thanks. 0
By : LuneAgile - at :- 10/14/2018 10:51:31 AM


profileImage Answered by:- manish

If you can't see this option this means you are using ASP.NET Core 1.1 in your project, such option does not exist in an ASP.NET Core (1.1) project, under web server settings the only available option is AppURL textbox.

If you are running asp.net core 1.x in Visual Studio 2017, you should be able to change the "sslPort": 0 line in the launchSettings.json file to whatever port number you would like to use for SSL. This effectively changes the bindings in the .\vs\config\applicationhost.config file

1
At:- 9/21/2018 7:09:08 PM
Hi Manish I'm using core 2.1. And still this option not appear inside my visual studio 2017. anyway how I can add it please. Thanks. 0
By : LuneAgile - at :- 10/13/2018 12:04:04 PM
Please double check, I can see the option in my Visual Studio when using Core 2.1. 0
By : manish - at :- 10/13/2018 12:57:11 PM


profileImage Answered by:- LuneAgile

Thanks. manish.

0
At:- 9/22/2018 10:14:30 AM





Login/Register to answer
Or
Register directly by posting answer/details

Full Name *

Email *




By posting your answer you agree on privacy policy & terms of use