Error "Connection was established with server but error occurred during login process" SSMS

When I am trying to login into my local database server using SQL server management studio, I am getting an error, as shown below

A connection was successfully established with the server, but then an error occurred during the login process. 
(provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.) 


How can I resolve this error? Thanks

Asked by:- bhanu
: 4461 At:- 8/3/2021 3:36:40 PM
SQL SQL Server connection error

2 Answers
profileImage Answered by:- pika

Looks like your SQL Server services might not be running, so you need to manually start SQL Server services.

If you are on Windows 10, you can open Configuration manager by

Control Panel -> Administrative tools -> Open Computer Management ->Services and Application -> SQl server configuration manager, below is the screenshot

Simply start "SQL Server" services, if it is stopped and then re-try.


If the above solution doesn't work, try below steps:

  • Open SQL Server Management Studio
  • Right-click on the instance
  • go to properties
  • Select Security
  • Under Server Authentication, enable "SQL Server and Windows Authentication Mode"
  • Click "OK" and try to connect now.

You may also like to check:

How to open sql server configuration manager in windows 10?

Cannot connect to WMI Provider SQL server configuration manager error

How to enable full text search on SQL Server database?

At:- 8/3/2021 3:47:05 PM
I had to start SQL Services, thanks 0
By : bhanu - at :- 8/3/2021 3:48:46 PM

profileImage Answered by:- vikas_jk

This Error occurs when SQL service was Stops working somehow on server but it can also occur due error in SQL Server Connection string in Code.

So you can add Trusted_Connection=True to the connection string.


Server=TheServerAddress; Database=TheDataBase; User Id=TheUsername; Password=ThePassword; TrustServerCertificate=True


In SSMS, Select "Connection Properties" tab when connecting to database, then

File -> Connect Object Explorer -> Options (bottom right) -> Connection properties tab -> Check "Trust Server Certificate" to make it true.

At:- 11/10/2022 12:19:37 PM

Login/Register to answer
Register directly by posting answer/details

Full Name *

Email *

By posting your answer you agree on privacy policy & terms of use