how to disable "Chrome script debugging in Visual Studio is enabled" in Visual Studio 2017?


How can I disable this debugging(image below), I'm using Visual Studio 2017 Community edition and don't like the new chrome window whenever I click Debug in Visual Studio using Chrome browser

Chrome-script-debugging-in-Visual-Studio-is-enabled-min.png

Does anyone know how to disable it?


Asked by:- neena
1
: 796 At:- 1/3/2018 9:18:04 AM
Visual Studio chrome script debugging in visual studio disable VS2017






2 Answers
profileImage Answered by:- Sam

This is the new feature of Visual Studio 2017, earlier we would have to use IE in debug mode to debug javascript, but now it is enabled in Visual Studio 2017 RC and later editions.

What happens is that Visual Studio is attaching to Chrome using the remote debugging protocol and then redirects to the ASP.NET project URL (something like http://localhost:12345) after it attaches. After the attach is complete, the “Please wait while we attach…” message remains visible while the ASP.NET site starts up where normally you’d see a blank browser during this time.

Once the debugger is attached, script debugging is now enabled for all JavaScript files in the project as well as all TypeScript files if there is source map information available.

You can disable this option by navigation to "Tools"-> "Options"-> Select "Debugging" (Left Pane) & "Enable Javascript debugging for ASP.NET (Chrome & IE) (uncheck this option)"

disable-the-new-debug-window-in-VS2017-min.png

2
At:- 1/3/2018 5:48:55 PM
Good answer 0
By : Vinnu - at :- 1/4/2018 2:46:40 PM


profileImage Answered by:- vikas_jk

Above answer is correct, But I would like to add few more details to it, first of all if you need to debug JavaScript again, just check the above mentioned settings again and you should be back to running the built-in browser and debugging again.

UPDATE (since version 15.17.1): To keep Visual Studio from opening a new window when debuging. Go into Tools -> Options then navigate into Projects and Solutions -> Web Projects and uncheck the option Stop debugger when browser window is closed.

stop-debugger-new-vs-version-min.png

That's it, we are done

0
At:- 6/6/2018 7:54:50 AM





Login/Register to answer
Or
Register directly by posting answer/details

Full Name *

Email *




By posting your answer you agree on privacy policy & terms of use

Subscribe Now

Subscribe to our weekly Newsletter & Keep getting latest article/questions in your inbox weekly